Home > Hyper-V R2, Windows 2008 R2 > Windows 2008 R2 Network Problem under heavy loads

Windows 2008 R2 Network Problem under heavy loads

I was facing this problem during the last month till I found this update, My testing server was holding around 12 VMs ( AD, Exchange 2010, SCOM, SCCM, TMG, etc… ) and we were facing a network problem, In heavy network loads some of the VMs got a disconnected NIC.

I found that TMG’s team is facing the same problem

If you’ve deployed your ISA Server, Microsoft IAG, Forefront TMG or Forefront UAG on Hyper-V R2 and noticed that a connection between the guest and the virtual switch starts “acting odd”, performs poorly or becomes disconnected entirely, you  may want to apply this update:

http://support.microsoft.com/kb/974909

Consider the following scenario:

  • You install the Hyper-V role on a computer that is running Windows Server 2008 R2.
  • You run a virtual machine on the computer.
  • You use a network adapter on the virtual machine to access a network.
  • You establish many concurrent network connections, or there is heavy outgoing network traffic.

In this scenario, the network connection on the virtual machine may be lost. Additionally, the network adapter is disabled.

Note You have to restart the virtual machine to recover from this issue.

You have to install this hotfix for this problem, Now everything is fine

Advertisements
  1. July 12, 2010 at 4:02 pm

    What you do on your blog is really great but more frequent updates, please.

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: