Home > VMM, VMM2012 > SCVMM 2012 VM Migration Error 2912

SCVMM 2012 VM Migration Error 2912

Symptom:

When you move VMs between different Windows 2008 R2 SP1 hosts you get this error

Error (2912)
An internal error has occurred trying to contact an agent on the Hostname server: NO_PARAM: NO_PARAM.
Unknown error (0x80072f0d)

Recommended Action
Ensure the agent is installed and running. Ensure the WS-Management service is installed and running, then restart the agent.

Cause:

1- VMM agent is not running

2- WMI or WinRM services are not running

3- VMM BITS port configuration need adjustment

 

Resolution:

Check VMM agent, WinRM, WMI Services and start if anyone stopped

  1. On Hyper-V Server, check if we have installed feature Background Intelligent Transfer Service (BITS) feature.
  2. Open Regedit and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft System Center Virtual Machine Manager Server\Settings
  3. Locate the BITSTcpPort name on the right. It’s data value should be 443
      a. Double click BITSTcpPort in order to modify the data. Make sure the Base is set to ‘Decimal’
      b. Change 443 to 765, or any other number less than 32768. Do not use a port that another protocol uses such as RDP (3389)
      c. Click ‘OK’ to save this value
  4. Restart the ‘Virtual Machine Manager’ and ‘Virtual Machine Manager Agent’ services on the SCVMM server. (On managed hosts simply restart the ‘Virtual Machine Manager Agent’ service’)
  5. Once complete on the SCVMM server and all Hosts you can continue using SCVMM

NOTE: Changing the BITS port for SCVMM does not affect BITS ports used by other applications or Windows itself.

Advertisements
Categories: VMM, VMM2012 Tags: ,
  1. Sebastian M.
    February 14, 2013 at 2:43 pm

    This also Counts for System Center 2012 Virtual Machine Manager SP1 installed on Windows Server 2012 and System Center 2012 App Controller SP1 on the same machine.
    Changing the BITS port for VMM has solved my issue.

  2. CypherMike
    March 23, 2013 at 11:49 am

    I changed the port as per instructions above since I want to install App Controller on the same VM as SCVMM 2012 SP1 is, but deployment of machines through templates fails. I opened a thread: social.technet.microsoft.com/…/519ed054-1d69-4084-9403-00b351fa192a

    It appears I’m not the only one with this issue: social.technet.microsoft.com/…/d50e46de-1418-4c6e-9333-91e8239db898

    Any assistance would be appreciated.

  3. Mohamed Fawzi
    March 24, 2013 at 9:45 am

    Please provide full links for forum threads

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: